Device fails to reconnect after the erasure error is shown
Created date | Updated date |
|---|---|
20-08-2024 | Nov 6, 2025 |
Problem
During the Erasure process, MacBook shows a pop-up "Device fails to reconnect after completed erasure, Manually Confirm the Success"
Cause
If we manually fail the erasure, the erasure report shows a failed status. However, if we manually confirm the erasure as successful, the report incorrectly shows an 'Erased' status even though the erasure failed."
Resolution
On the BEAD host machine, ensure that the device lock timer is turned off, or keep the BEAD machine active throughout the erasure process.
During firmware loading on the client machine, the BEAD machine will request permission to "Allow an accessory to connect." It is crucial to respond to this pop-up by clicking "Yes." Failing to do so will cause the client machine to remain disconnected for an extended period, resulting in the BEAD machine offering the option to "manually confirm the erasure."
After the firmware is loaded, another pop-up will appear asking to "Allow an accessory to connect." This pop-up can appear multiple times, and you need to click "Allow" each time. Or else you can set the setting for the "Allow Accessories to connect: Automatically when Unlocked" which will also save the interaction with the BEAD machine. Please refer to the Screenshot for the same:
To maintain communication between the BEAD machine and the targeted Mac devices throughout the process, always grant permission on the BEAD host machine by allowing the accessory (the client machine) to connect.